HD Видеоконференции на OpenMCU



Добавлено зеркало для сайта и форума. http://videoswitch.ru/
Если будут проблемы с доступом - все изменения так же будут отображены в github репозитории.

Автор Тема: Video have block issue when object moving fast  (Прочитано 1303 раз)

bendney

  • Новичок
  • *
  • Сообщений: 31
  • Карма: 0
Video have block issue when object moving fast
« : 25 Сентября 2016, 12:44:25 »
linphone desktop using H.264 call in with 720P, video have block issue when object moving fast. I tried to increase bitrate and bandwith, both doesn't work. It's really effect the video quality.

The issue happened in openmcu 4.1.6 version and linphone 3.9.1.

blanchae

  • Постоялец
  • ***
  • Сообщений: 155
  • Карма: 6
    • Telecomworld 101
Re: Video have block issue when object moving fast
« Ответ #1 : 26 Сентября 2016, 23:43:00 »
You might be running into a quality of service (QoS) issue if the video is running on the same network as data or voice. What QoS policies do you have going? VLAN'd network, etc..?


Also, is OpenMCU-ru on a stand-alone server?

bendney

  • Новичок
  • *
  • Сообщений: 31
  • Карма: 0
Re: Video have block issue when object moving fast
« Ответ #2 : 27 Сентября 2016, 05:51:49 »
Just in LAN network, OpenMCU-ru running on stand-alone server with ubuntu 14.04 machine.

blanchae

  • Постоялец
  • ***
  • Сообщений: 155
  • Карма: 6
    • Telecomworld 101
Re: Video have block issue when object moving fast
« Ответ #3 : 27 Сентября 2016, 23:20:26 »
H.264 and other video codecs compress the video. To get the high compression, it keeps track of what changes and what remains the same in a video. Usually, the background doesn't change so once the background image is transferred, it doesn't update the background. Anything that moves is sent and drawn overtop of the background. If you have video moving fast across the screen then the codec may be having issues updating and display "artificats" or blocks across the screen.

bendney

  • Новичок
  • *
  • Сообщений: 31
  • Карма: 0
Re: Video have block issue when object moving fast
« Ответ #4 : 13 Декабря 2016, 04:58:53 »
Do you have any solution to solve this? Or OpenMcu-ru itselfe  have parameters settings to avoid this happened?