HD Видеоконференции на OpenMCU



23.01.2015. Выпущен релиз OpenMCU-ru 4.0. Исправлены ошибки, проведена оптимизация, добавлен встроенный регистратор, появилась возможность совершать внутренние вызовы между терминалами, реализовано шифрование SIP (TLS, SRTP, ZRTP), новые кодеки G.722.1, G.722.1 Annex C, G.722 (AMR-WB), MPEG4 (MP4V-ES), NAT для SIP и многое другое.

Автор Тема: Не работает ссылка на пакеты для линукса  (Прочитано 2368 раз)

Ismat

  • Новичок
  • *
  • Сообщений: 3
  • Карма: 0

kay27

  • Глобальный модератор
  • Ветеран
  • *****
  • Сообщений: 3065
  • Карма: 58
http://openmcu.ru/public/OpenMCU-ru/ALT_Linux/p7/ Не работает эта ссылка

папки реорганизованы :(
надо либо вернуть, либо исправлять теперь все ссылки. откуда эта?
правильная сейчас такая: http://openmcu.ru/public/OpenMCU-ru/3.48/ALT_Linux/p7/

Ismat

  • Новичок
  • *
  • Сообщений: 3
  • Карма: 0
На главной станице щелкнул на установку линукс, и там была эта ссылка на пакеты, спасибо вам большое за то что среагировали на мою проблему

kay27

  • Глобальный модератор
  • Ветеран
  • *****
  • Сообщений: 3065
  • Карма: 58
Исправил ссылку в документации.
Получилось довольно криво: из вики ссылка конкретно на версию 3.48.
Если даже когда-то появится пакет версии 4.0, ссылки на неё из вики уже не будет.

Думаю, целесообразно вернуть пакеты обратно... xak?
« Последнее редактирование: 02 Декабря 2015, 12:10:19 от kay27 »

xak

  • Разработчик
  • Ветеран
  • *****
  • Сообщений: 1791
  • Карма: 58
Думаю, целесообразно вернуть пакеты обратно... xak?
Давно дело было, это я делал изменение структуры каталогов ftp. Тогда кроме как для Centos никакие пакеты больше никем не собирались, поэтому при открытии "http://openmcu.ru/public/OpenMCU-ru/" только в "Centos" были бы пакеты для 4.0/4.1. Предполагалось, что если будут пакеты для других систем, то для них будут каталоги "http://openmcu.ru/public/OpenMCU-ru/4.1/ALT_Linux/p7/" и т.п..
Будут или не будут пакеты неизвестно, скорее всего нет :)
Для использования лучше собрать из исходников 4.0/4.1 чем ставить 3.48.

kay27

  • Глобальный модератор
  • Ветеран
  • *****
  • Сообщений: 3065
  • Карма: 58
Будут или не будут пакеты неизвестно, скорее всего нет :)

Создал тему в спецразделе, чтобы зафиксировать пути.
Отсутствие свежих пакетов - не очень хороший повод менять структуру, много чего пострадало, я бы вернул всё обратно.

rayanAyar предложил ещё такую организацию:

Конструктивно именно по данной теме - если уж хочется сделать отдельные подпапочки для каждой версии - пожалста, это делается элементарно. И не мной это придумано, а давно уже в сообществе выработан классический способ:
делаются подпапки с версиями:
/public/OpenMCU-ru/4.0/
/public/OpenMCU-ru/4.1/
/public/OpenMCU-ru/4.2/
/public/OpenMCU-ru/4.3/
И делают симлинки:
/public/OpenMCU-ru/stable -> ./4.2/
/public/OpenMCU-ru/testing -> ./4.3/

И все ссылки на репозитории указываются на симлинки, а не на папки. Когда нужно - симлинк меняется на следующую папку.
И в вики тогда не надо будет каждый раз переделывать ссылки, и обновление ломаться не будет.

Надо определиться и зафиксировать пути; если это не сделать, то шанс органично влить свежие пакеты уменьшится, даже если кто-то их соберёт.

xak

  • Разработчик
  • Ветеран
  • *****
  • Сообщений: 1791
  • Карма: 58
Отсутствие свежих пакетов - не очень хороший повод менять структуру, много чего пострадало, я бы вернул всё обратно.
Смысл возвращать? Тогда была неопределенность, сейчас уже понятно, что пакетов нет и не будет. Зачем предлагать пользователям ссылку на старую и к тому же не совсем удачную версию? Лучше уже нигде особо не учитывать, что когда то эти пакеты были, а в вики дать ссылку на папку "OpenMCU-ru" или на старый пакет с пометкой типа - "рекомендуется собрать из исходников версию 4".

Тоже касается и:
сломана система обновлений пакетов Debian
Если она не обновляется, то - это уже не система обновлений. Было бы хорошо, если бы автор этой системы уведомил всех о том, что она больше не будет поддерживаться, и тогда бы не возникло той "неопределенности". И это тоже убрать из вики или сделать пометку о версии.

kay27

  • Глобальный модератор
  • Ветеран
  • *****
  • Сообщений: 3065
  • Карма: 58
Зачем предлагать пользователям ссылку на старую и к тому же не совсем удачную версию?
Хм... Затем, что текущая версия в чём-то ещё менее удачная, например? :)
Кому-то такой будет достаточно. Кому недостаточно - те потенциальные сборщики пакетов.

Было бы хорошо, если бы автор этой системы уведомил всех о том, что она больше не будет поддерживаться, и тогда бы не возникло той "неопределенности". И это тоже убрать из вики или сделать пометку о версии.
Проект открыт, ушёл один, придёт другой.
Поддерживается/не поддерживается, откуда мы знаем? rayanAyar обновлял 3.48 и, судя по всему, может продолжать это делать. vol4enok начинал разбираться с 4.0, и не он один... насколько я понял, там есть какие-то сложности. Кто-то когда-то их преодолеет, наверное.

Сейчас нужно зафиксировать ссылки в том или ином виде, исправить ошибки и двигаться дальше

xak

  • Разработчик
  • Ветеран
  • *****
  • Сообщений: 1791
  • Карма: 58
Хм... Затем, что текущая версия в чём-то ещё менее удачная, например? :)
Кому-то такой будет достаточно. Кому недостаточно - те потенциальные сборщики пакетов.
Не смог вспомнить чем:) 4.0 как минимум стабильнее, но в общем согласен, вкусы у всех разные.

Сейчас нужно зафиксировать ссылки в том или ином виде, исправить ошибки и двигаться дальше
Не знаю как лучше. В вики для разных систем: ссылка на файл - старая версия, ссылка на папку "OpenMCU-ru" - большинство только в 3.48, структура каталогов как было раньше - новая версия не на виду.